Unable to Retrieve rates or creating Conversions
Incident Report for Currencycloud
Resolved
This incident has been resolved.
Posted Feb 21, 2024 - 22:34 UTC
Investigating
We are experiencing a problem retrieving rates and creating new conversions, this is due to a 3rd party outage and we are working with the supplier on fixing the problem.
Posted Feb 21, 2024 - 21:20 UTC
This incident affected: Conversions.