Potential SEK Delays

Incident Report for Currencycloud

Resolved

The root cause of the issue was identified and resolved in coordination with our SEK network partners. All impacted payments have now been successfully processed and will be completed according to the instructed value date.

No further action is required. However, if you experience any issues or have questions, please contact our customer services team for assistance.

Thank you for your patience.
Posted Jul 08, 2025 - 15:05 UTC

Monitoring

Root cause with SEK network partners has been identified, and the underlying issue has been resolved. Impacted payments have resumed processing and will be completed according to the instructed value date. Active monitoring is ongoing, and further updates will be provided as necessary.
Posted Jul 08, 2025 - 12:21 UTC

Identified

We are currently experiencing potential delays in processing SEK currency transactions due to issues with our network providers. We are working closely with them to resolve the matter as quickly as possible and appreciate your patience and understanding.
Posted Jul 08, 2025 - 09:46 UTC
This incident affected: Payments.