Delay in Swift Payments Value dated 10th Feb

Incident Report for Currencycloud

Postmortem

Overview

On Monday, February 10th, some clients experienced a failure rate for PLN instructions, across SWIFT and local routes for HUF, CZK, and RON.

The issue was immediately addressed, but some clients may have experienced a 1-day processing delay due to early currency cut-off times.

Confidential © Currencycloud 2025

This memo furnished to you solely in your capacity as a client of Currencycloud and/or a participant in the Visa payments system. By accepting this memo you acknowledge that the information contained herein (the “Information”) is confidential and subject to the restrictions contained in confidentiality agreements, which limit your use of the Information. You agree to keep the Information confidential and not to use the Information for any purpose other than in your capacity as a customer of Currencycloud or as a participant in the Visa payments system. The Information may only be disseminated within your organization on a need-to-know. Please be advised that the Information may constitute material non-public information under U.S. federal securities laws and that purchasing or selling securities of Visa Inc. while being aware of material non-public information would constitute a violation of applicable U.S. federal securities laws.

Posted Feb 24, 2025 - 09:35 UTC

Resolved

This incident has been resolved.
Posted Feb 11, 2025 - 09:49 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 10, 2025 - 11:44 UTC

Investigating

Due to a technical issue the following currencies have been impacted and will be delayed by one day.

CHF, CZK, DKK, HUF, MXN, NOK, PLN, RON, SEK, TRY, ZAR

Issue has been resolved and root cause to follow.
Posted Feb 10, 2025 - 11:43 UTC
This incident affected: Payments.