Delay completing local CZK Payments
Incident Report for Currencycloud
Resolved
Issue has been resolved and payments are now showing completed
Posted Sep 13, 2022 - 12:20 UTC
Investigating
We are working with our payment provider to resolve and issue with local CZK, payments have been submitted we are waiting to update the status
Posted Sep 13, 2022 - 10:08 UTC
This incident affected: Payments.