Delay updating LOCAL EUR payment status
Incident Report for Currencycloud
Resolved
This incident has been resolved.
Posted Apr 12, 2024 - 14:51 UTC
Investigating
We are currently investigating an issue with updating the local EUR payment status.
Current impact is only to the status of the payments. Payments are being submitted to our local provider.
Posted Apr 12, 2024 - 13:06 UTC
This incident affected: Payments.