Increase in LOCAL EUR payments failing
Incident Report for Currencycloud
Resolved
The issue has been resolved by our provider

Payments that failed will need to be resubmitted
Posted Dec 15, 2023 - 14:57 UTC
Identified
Issue has been identified with our provider we are working with them to get this resolved as soon as possible
Posted Dec 15, 2023 - 11:39 UTC
Update
We are working with our provider to understand the increase in failures
Posted Dec 15, 2023 - 11:00 UTC
Investigating
We are investigating an increase in LOCAL EUR payment failures, this issue is not impacting all payments.

Payments are failing with unable to apply

We are investigating the cause of this increase and will provide an update as soon as possible.
Posted Dec 15, 2023 - 10:44 UTC
This incident affected: Payments.