RON, CZK & HUF Processing Delays
Incident Report for Currencycloud
Postmortem

Cause and Impact

On Tuesday 26 November 2024, one of our banking network partners experienced a technical issue with a hardware component in their payment transaction system which resulted in a momentary loss of connectivity. Upon return, the impacted hardware component was unable to accept inbound funding transactions.

To mitigate further client impact and avoid possibility of duplication, a small amount of submission files issued by Currencycloud were failed back to clients under automatic notification.

Remediation

A prompt resolution was achieved returning the service to expected behaviour on Thursday 28 November 2024. Funding successfully credited allowing sufficient balance for customer impacted payments value dated 27 November to process with a one-day delay.

Confidentiality Disclaimer
Important Information on Confidentiality and Copyright
© 2014—2024 Visa. All Rights Reserved.
Notice: This information is proprietary and CONFIDENTIAL to Visa. It is distributed to Visa

participants for use exclusively in managing their Visa programs. It must not be duplicated, published, distributed or disclosed, in whole or in part, to merchants, cardholders or any other person without prior written permission from Visa. The trademarks, logos, trade names and service marks, whether registered or unregistered (collectively the “Trademarks”) are Trademarks owned by Visa. All other trademarks not attributed to Visa are the property of their respective owners.

Posted Dec 16, 2024 - 10:51 UTC

Resolved
This incident has been resolved.
Posted Nov 29, 2024 - 13:01 UTC
Identified
Due to an issue with our banking provider, RON, CZK & HUF payments instructed for value date Tuesday 26th November may experience a delay in processing, we are working to resolve on priority
Posted Nov 28, 2024 - 09:13 UTC
Investigating
We are currently experiencing delays with RON, CZK & HUF processing due to an issue with our banking provider, we are working to resolve on priority
Posted Nov 26, 2024 - 12:27 UTC
This incident affected: Payments.