Unable to Quote or Book APAC Trades
Incident Report for Currencycloud
Resolved
This incident has been resolved.
Posted Jun 20, 2022 - 18:24 UTC
Update
We are continuing to work with our FX provider to resolve the issue.
Posted Jun 20, 2022 - 16:35 UTC
Investigating
We are currently investigating an issue impacting booking trades for APAC currencies. We have reached out to our FX provider to help resolve this issue.
Posted Jun 20, 2022 - 15:23 UTC
This incident affected: Conversions.