Delay to local DKK payments

Incident Report for Currencycloud

Postmortem

Overview:

On 6th October, a disruption affected the processing of DKK payments. Our team promptly engaged with our local DKK network partner to investigate and resolve the issue, restoring normal service quickly.

Impact:

The impact was minimal, with the majority of payments successfully processed to their intended value date (06/10). Some payments experienced a delay, but no data loss or financial errors occurred.

Root Cause:

The incident was traced to our network partner’s systems. Initially, an upstream queue failure caused some payments to be misrouted before reaching our processing system. Additionally, a recent platform update changed a key interface element, which temporarily disrupted our automated processing scripts. Both issues were external to our core systems.

Remediation:

Our automation scripts were promptly updated to accommodate the platform changes, and the fix was deployed. We continue to work closely with the network partner to address the upstream queue issue and ensure long-term stability. Ongoing monitoring remains in place to prevent recurrence.
We appreciate your patience and remain committed to delivering reliable payment services.

Posted Oct 15, 2025 - 07:25 UTC

Resolved

Issue affecting the processing of DKK payments is resolved. The majority of transactions have now been successfully processed with their correct value date. Our team will continue to monitor the situation closely in collaboration with our network partners to ensure full stability.
Posted Oct 06, 2025 - 14:50 UTC

Investigating

We are currently investigating a potential issue affecting the processing of DKK payments. Our team is working closely with network partners to resolve this as quickly as possible.
Posted Oct 06, 2025 - 13:24 UTC
This incident affected: Payments.