Potential Euro Processing Delay

Incident Report for Currencycloud

Postmortem

Overview

A system update impacted the setup of new EUR Virtual IBANs, resulting in a temporary delay to some EURO payments for newly added payers. Payments for existing payers continued to process as normal.

The issue was quickly identified and fully resolved with services operating as expected.

Client Impact

A small number of EURO payments were delayed by one day.

We appreciate your patience and understanding.

Posted Aug 26, 2025 - 08:18 UTC

Resolved

The earlier issue affecting some EURO payments has been fully identified and resolved. All payments are now processing as normal. Thank you for your patience.
Posted Aug 22, 2025 - 11:17 UTC

Identified

We are aware of an issue affecting some EURO payments. Our team is actively working to resolve. Majority of payments are processing normally, however a small number may experience slight delays. Thank you for your patience.
Posted Aug 22, 2025 - 09:33 UTC
This incident affected: Payments.