Confirmation of Payee - Degraded
Incident Report for Currencycloud
Resolved
This incident has been resolved.
Posted Dec 12, 2023 - 10:45 UTC
Update
Our 3rd party provider is still working to resolve the issue as soon as possible
Posted Dec 11, 2023 - 17:52 UTC
Investigating
Some clients may experience an issue with validating new payees.

Clients may see the error "account number does not exist".

This is being actively worked on as a priority
Posted Dec 11, 2023 - 15:34 UTC
This incident affected: Balances.