Confirmation of Payee Inbound - Degraded
Incident Report for Currencycloud
Postmortem

Overview

On Tuesday 14th January the confirmation of payee file upload was temporarily interrupted due to an out-of-hours maintenance restart.

This resulted in the inability of a few Client accounts being updated to be and validated via confirmation of payee when funding their Currencycloud local GBP accounts.

The impacted accounts were immediately remediated as part of the daily upload, completed at 01:00 AM on Wednesday 15th January.

Client Impact

Confirmation of Payee updates since the last file generation 2025-01-13 01:00:00 were not reflected, nor were accounts that have been deleted or disabled.

As of 1:00 AM on Wednesday 15th January, all impacted accounts remained fundable.

Confidentiality Disclaimer

Confidential © Currencycloud 2024
This memo furnished to you solely in your capacity as a client of Currencycloud and/or a participant in the Visa payments system. By accepting this memo you acknowledge that the information contained herein (the “Information”) is confidential and subject to the restrictions contained in confidentiality agreements, which limit your use of the Information. You agree to keep the Information confidential and not to use the Information for any purpose other than in your capacity as a customer of Currencycloud or as a participant in the Visa payments system. The Information may only be disseminated within your organization on a need-to-know. Please be advised that the Information may constitute material non-public information under U.S. federal securities laws and that purchasing or selling securities of Visa Inc. while being aware of material non-public information would constitute a violation of applicable U.S. federal securities laws.

Posted Jan 21, 2025 - 15:33 UTC

Resolved
This incident has been resolved.
Posted Jan 15, 2025 - 08:28 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 14, 2025 - 16:44 UTC
Investigating
We are investigating an issue that could impact some clients ability to validate their accounts via confirmation of payee when funding their Currencycloud local GBP account.

Accounts updated between 2025-01-13 01:00:00 and 2025-01-14 01:00:00 are impacted
Posted Jan 14, 2025 - 10:22 UTC
This incident affected: Balances.