Microsoft outage - Impact to Currencycloud
Incident Report for Currencycloud
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 11:18 UTC
Investigating
We are working with our external partners to understand the impact of this outage.

Currently we are experiencing issues supporting requests for further information on transactions.

All other services are working as expected but we will update accordingly as more information becomes available
Posted Jul 19, 2024 - 09:55 UTC
This incident affected: API, Payments, Conversions, Paydirect.io / Direct, Notifications, Balances, and Other.