Webhook notifications are being processed and delivered normally. The backlog of delayed notifications has been fully cleared and service continued to operate throughout the incident.
Engineering has implemented remediation measures and no further delays are expected. We will continue to monitor the service as part of normal operations. No client action is required.
Posted Sep 08, 2026 - 16:12 UTC
Monitoring
Webhook notifications continue to be processed and delivered, although some clients may still experience delays while recovery activities remain in progress.
Engineering has deployed an additional change designed to reduce database load and improve processing throughput. This update is currently being rolled out and early indicators show backlog volumes continuing to reduce. In parallel, a further corrective change addressing the underlying cause has been identified and is undergoing final review prior to deployment.
We are actively monitoring service performance and backlog reduction as processing returns to normal levels. No client action is required at this time.
Posted Sep 08, 2026 - 15:21 UTC
Identified
We have identified the cause of delays affecting webhook notification delivery and are implementing a phased remediation plan.
Our immediate priority is to restore normal processing rates and reduce the backlog of delayed notifications. In parallel, Engineering is implementing a corrective change to address the underlying issue and prevent recurrence.
Clients may experience delays in receiving webhook notifications while recovery activities are ongoing. We are actively monitoring progress and will continue to provide updates as service recovers.
No client action is required at this time.
Posted Sep 08, 2026 - 14:15 UTC
Investigating
We are currently investigating delays affecting the delivery of webhook notifications.
Our teams are actively reviewing the issue and working to restore normal service.
We will provide further updates as more information becomes available.