Delay to RON Local Payments Processing

Incident Report for Currencycloud

Postmortem

Overview

On June 15, 2026, we identified an issue affecting a subset of RON local payments, where a payment file sent to a network partner was not successfully processed, resulting in delays.
The incident was fully resolved within approximately 42 hours and 30 minutes following successful re-submission of the file.

Client Impact

A subset of payments were delayed and remained in a submitted state during the incident.
All payments were processed successfully after resolution. No client action was required, and there were no data integrity, security, or financial impacts.

Root Cause

The network partner received an incomplete payment file, which could not be processed.
Internal checks confirmed that the file was complete on our side, indicating the issue likely occurred during transmission. The file was successfully re-submitted, resolving the issue.

Currencycloud Confidential
Posted Jun 24, 2026 - 08:51 UTC

Resolved

This incident has been resolved.
Posted Jun 17, 2026 - 09:23 UTC

Investigating

We are currently investigating an issue impacting a subset of RON local payments, where a file has not been successfully processed by an external network partner.

This is resulting in delays to affected payments, and our teams are actively working with the partner to validate and progress resolution.

Further updates will follow.
Posted Jun 15, 2026 - 16:13 UTC
This incident affected: Payments.