Operational Delays to Manual Processing Activities

Incident Report for Currencycloud

Resolved

The issue has been identified and resolved, and services are operating normally.

Our teams have validated recovery and continue to monitor the environment to ensure ongoing stability.

At this time, we do not expect any impact or delays.

Thank you for your patience while we investigated and resolved the issue.
Posted Jul 20, 2026 - 12:04 UTC

Investigating

We are currently investigating an issue affecting internal access systems used by operational teams.

Whilst payment processing services remain available, some manually processed activities, including funds allocation, sender verification and investigation-related requests, may experience delays.

Our teams are actively working to restore full service and we will continue to provide updates as available.
Posted Jul 20, 2026 - 09:32 UTC
This incident affected: Payments and Other.