Processing delays TRY, CHF & MXN local payments

Incident Report for Currencycloud

Postmortem

Overview 

On 5 June 2026, a technical change in our production environment affected how the status of some local payments in TRY, CHF and MXN was displayed. 

This lasted approximately 6 hours, during which some payments appeared to be delayed because their status was not updating as expected. 

The situation was resolved through a service update, after which normal processing resumed. A follow‑up remediation was completed to ensure all affected payments reflected the correct final status. 

Client Impact 

During this period, some customers may have seen their payments remain in a “submitted” status for longer than expected. 

We want to reassure you that payments continued to be processed successfully by our network providers, and funds were transferred as normal. 

The impact was limited to how payment statuses were displayed in the platform. All affected payment statuses have since been corrected, and no action is required from customers. No data integrity concerns were identified. 

Root Cause 

This was related to a recent application update affecting how payment status messages are handled. 

As a result, some status updates from external network providers were not reflected correctly in the platform. 

Currencycloud Confidential

Posted Jun 09, 2026 - 19:25 UTC

Resolved

The issue has now been resolved, and the service is operating as expected.

A small subset of payments may continue to display an incorrect status; this is currently under investigation, and further updates will be provided once resolution is confirmed.
Posted Jun 05, 2026 - 15:00 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 05, 2026 - 10:37 UTC

Identified

We are currently experiencing delays in the processing of some local payments in TRY, CHF and MXN.

Payments may take longer than usual to complete while we investigate the issue with our external banking partners. We are working to resolve this as quickly as possible and will provide further updates as soon as more information becomes available.
Posted Jun 05, 2026 - 08:48 UTC
This incident affected: Payments.