Bulk Upload Service – Temporary Unavailable

Incident Report for Currencycloud

Resolved

The issue impacting the Bulk Upload feature has now been resolved.

We will continue to monitor closely to ensure ongoing stability of this feature.
Posted Feb 24, 2026 - 15:38 UTC

Update

We are continuing to work on a fix for this issue.
Posted Feb 20, 2026 - 09:33 UTC

Identified

We are currently experiencing an issue with the Bulk Upload feature. As a temporary measure, the service has been disabled while our team works on a resolution.

All other platform functionality remains operational.

We will provide an update as soon as more information becomes available.
Posted Feb 20, 2026 - 09:31 UTC
This incident affected: Paydirect.io / Direct.