Virtual account creation service degraded

Incident Report for Currencycloud

Resolved

Issue has been mitigated and all vans have been created.
Posted Apr 28, 2026 - 17:15 UTC

Update

We are working with our Banking Partner to resolve this issue and will update once the issue has been resolved.
Posted Apr 28, 2026 - 10:13 UTC

Investigating

We are currently investigating an issue affecting the functionality to create CAD virtual accounts.
Posted Apr 28, 2026 - 07:32 UTC
This incident affected: Other.