Delay in Virtual Account Creation.

Incident Report for Currencycloud

Resolved

This incident has been resolved.
Posted Jan 13, 2026 - 11:28 UTC

Investigating

We are investigating reports of delays in USD Virtual Account Creation.

Accounts are taking longer to activate than expected.
Posted Jan 13, 2026 - 09:08 UTC
This incident affected: Other.