Local EUR Payment Status

Incident Report for Currencycloud

Postmortem

Overview

On May 8th 2026, an issue was identified that affected the way status updates were displayed for local EUR payments. While payments continued to process normally, some statuses did not update in real time due to increased processing volumes. The issue was investigated, corrected, and status updates returned to normal.

Client Impact

During the incident, a subset of local EUR payments temporarily displayed an incorrect status, such as remaining marked as “Submitted.” There was no impact to payment execution or settlement, and all payments were processed as expected.

Root Cause

The issue was caused by an internal processing backlog triggered by an unusually high volume of payments released via our network partners within a short time frame. This delayed the handling of completion updates, resulting in slower status updates until processing capacity recovered and the backlog cleared.

 

Currencycloud Confidential
Posted May 13, 2026 - 08:05 UTC

Resolved

Payment statuses have been updated, now fully reflect their final status.

During this period payments have continued to process and settle as expected throughout.

Thank you for your patients.
Posted May 08, 2026 - 15:40 UTC

Monitoring

The issue affecting status updates for local EUR payments has been corrected.

Payment statuses are updating correctly; however, due to earlier processing volumes, it may take a few hours for all outstanding payments to fully reflect their final status.

Payments have continued to process and settle as expected throughout. We will continue to monitor closely until all status updates are fully reconciled.
Posted May 08, 2026 - 11:35 UTC

Investigating

We are currently experiencing an issue affecting the status updates for local EUR payments.

While the displayed status may not reflect the latest state, payments themselves are processing as expected with no impact to settlement.

Our teams are actively working to restore correct status reporting. We will provide a further update once the issue is resolved.
Posted May 08, 2026 - 10:57 UTC
This incident affected: Payments.