Quote time outs booking conversions (Non APAC) currencies.
Incident Report for Currencycloud
Resolved
The issue has been resolved
Posted Sep 15, 2022 - 22:24 UTC
Investigating
We are monitoring an issue with create conversions for non APAC trades, the service has not recovered after the 90 second daily downtime from 17:00 ET.

Issue has been raised with the FX provider to resolve the issue.
Posted Sep 15, 2022 - 21:37 UTC
This incident affected: Conversions.