Demo Environment – Login and API Connectivity Issues

Incident Report for Currencycloud

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 12:27 UTC

Investigating

We are currently investigating an issue affecting login and API connectivity within our Demo testing environment. Some clients may experience difficulty accessing the demo platform or making API requests.

Our engineering team is actively working to identify and resolve the issue as quickly as possible.

Important: This issue only affects the Demo environment used for testing and development. Our live production environment is operating normally and is not impacted.

We will provide further updates as soon as more information becomes available.

We appreciate your patience while we work to resolve this.
Posted Mar 12, 2026 - 09:18 UTC
This incident affected: API and Other.