Virtual account creation service degraded

Incident Report for Currencycloud

Resolved

Incident was resolved 20:00 UTC 14th Jan

Customers are advised to call the /v2/funding_accounts/find endpoint to pull the required Virtual Account Details
Posted Jan 15, 2026 - 09:37 UTC

Investigating

We are currently investigating an issue affecting the functionality to create USD virtual accounts.
Posted Jan 14, 2026 - 19:46 UTC
This incident affected: Other.