Degraded Performance – Local DKK Payments

Incident Report for Currencycloud

Resolved

The issue affecting a subset of DKK payments has been resolved.

Payment processing has returned to normal, and any delayed transactions are now being completed. We will continue to monitor closely to ensure ongoing stability.

Thank you for your patience.
Posted Apr 01, 2026 - 09:33 UTC

Investigating

We are currently investigating an issue affecting a subset of DKK payments. Customers may experience delays in processing due to an issue with one of our network partners.

Our team is actively working with the partner to resolve the issue as quickly as possible.

We will provide further updates as soon as more information becomes available.
Posted Mar 31, 2026 - 17:37 UTC
This incident affected: Payments.