Intermittent Two‑Factor Authentication Issues

Incident Report for Currencycloud

Postmortem

Overview

On May 7th 2026, an issue was identified that caused intermittent errors during two‑factor authentication for a subset of users. The problem was detected through monitoring and user reports, and teams investigated to isolate the cause. Once identified, changes were made to stabilize authentication behavior and restore normal access.

Client Impact

During the incident, some users experienced intermittent difficulty completing multi‑factor authentication when logging in. The issue was temporary, did not affect all users, and normal login functionality was restored once the corrective actions were completed.

Root Cause

The incident was caused by an internal application change related to session handling that unintentionally affected the authentication flow. This resulted in elevated error rates during multi‑factor authentication until the change was rolled back and stability was restored.

 

Currencycloud Confidential
Posted May 13, 2026 - 08:01 UTC

Resolved

The issue affecting Authy two‑factor authentication (2FA) has been resolved and customers should now be able to log in as normal.

We will continue to monitor authentication services to ensure ongoing stability.

Thank you for your patience while this was investigated.
Posted May 07, 2026 - 16:13 UTC

Investigating

We are currently aware that some customers may experience intermittent issues when using Authy for two‑factor authentication (2FA), which may affect the ability to log in.

While we investigate this, customers experiencing issues are advised to temporarily use SMS‑based verification where available as an alternative method.

Our teams are monitoring the situation closely and we will provide further updates as more information becomes available. We apologise for any inconvenience caused and thank you for your patience.
Posted May 07, 2026 - 11:16 UTC
This incident affected: Paydirect.io / Direct.