FX Trade Date Amendments and BARX Execution Failures

Incident Report for Currencycloud

Resolved

The issue impacting certain GBP currency pairs, including GBP/USD and GBP/EUR, has now been resolved.

The root cause was identified as an external network partner issue. The partner has confirmed remediation, and services have been fully restored. Trade date amendments and BARX executions are now processing as expected.

We will continue to monitor closely to ensure ongoing stability.
Posted Feb 17, 2026 - 17:31 UTC

Investigating

We are currently investigating an issue affecting certain FX transactions involving GBP currency pairs, including GBP/USD and GBP/EUR.

Clients may experience failures when submitting trade date amendments for FX deals or when executing trades via BARX in impacted pairs.

Our technical teams are actively working to identify the root cause and restore normal service as quickly as possible.
Posted Feb 17, 2026 - 17:15 UTC
This incident affected: Conversions.