The issue affecting a number of SEK payments has been fully resolved. All delayed payments have now been processed successfully, and payment processing is operating as expected.
Our teams have continued to monitor the service following the correction and have confirmed normal processing has been restored.
We apologise for any inconvenience caused and thank you for your patience while we worked to resolve the issue.
Posted Aug 13, 2026 - 07:46 UTC
Monitoring
The issue affecting a number of SEK payments has been corrected and payment processing has resumed.
We are continuing to monitor the service to ensure all delayed payments are processed successfully and that normal operations are maintained. We apologise for any inconvenience caused.
Posted Aug 12, 2026 - 13:18 UTC
Investigating
We are currently investigating a delay affecting a number of SEK payments being processed via our banking partners. As a result, some payments may take longer than expected to complete.
Our teams are actively engaged with the partners to resolve the issue and restore normal processing as quickly as possible. We will provide further updates as more information becomes available.