Unable to get rate for KWD

Incident Report for Currencycloud

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 21:41 UTC

Investigating

We are investigating an issue that is impacting clients attempting to get a rate for KWD, we are working with our FX Partner to resolve the issue as soon as possible
Posted Feb 20, 2026 - 18:44 UTC
This incident affected: Conversions.