The issue affecting errors when creating payments or logging in have been resolved. Service restored to expected behaviour. We apologize for any inconvenience this may have caused.
Posted May 22, 2026 - 05:35 UTC
Monitoring
Some clients experienced errors when creating payments or logging in due to issues with authentication checks. The issue was linked to a recent service change that affected how authentication requests were processed, but this has now been rolled back, and systems are stable with no repeated errors seen. We are currently confirming recovery with affected clients and continuing to monitor for any further issues.
Posted May 22, 2026 - 01:18 UTC
Investigating
We are currently investigating an issue causing some clients to receive Invalid SCA errors. Some clients experienced errors when creating payments or logging in due to issues with authentication checks. The issue was linked to a recent service change that affected how authentication requests were processed, but this has now been rolled back, and systems are stable with no repeated errors seen. We are currently confirming recovery with affected clients and continuing to monitor for any further issues.