Delays settling transactions
Incident Report for Currencycloud
Resolved
Issue as been resolved, scaled up instances to clear the queue. Will leave the system scaled up
Posted Sep 12, 2022 - 13:27 UTC
Investigating
We are experiencing an issue settling trades, deposits, transfers and margin releases from available balances and are urgently investigating
Posted Sep 12, 2022 - 13:10 UTC
This incident affected: Balances.