Delay in Creating EUR and USD Accounts in DEMO Environment

Incident Report for Currencycloud

Resolved

This incident has been resolved.
Posted May 19, 2026 - 08:51 UTC

Monitoring

The issue that may have caused delays or missing details during the creation of some EUR and USD accounts in the DEMO environment has been identified and mitigated.

Our teams are continuing to monitor the service to confirm normal processing has resumed.

Thank you for your patience, and we apologize for any inconvenience caused.
Posted May 18, 2026 - 20:14 UTC

Investigating

We are currently investigating an issue causing delays or missing details during the creation of some EUR and USD accounts in the DEMO environment.

Our teams have implemented a fix to improve processing, and new account creations are now progressing as expected.

We are continuing to monitor the situation and will address any remaining affected accounts.
Thank you for your patience, and we apologize for any inconvenience caused.
Posted May 18, 2026 - 17:05 UTC
This incident affected: Other.