Delay to local DKK payments

Incident Report for Currencycloud

Postmortem

Overview

On June 27, 2026, we identified an issue affecting a subset of DKK local payments, where a sweep submitted to a network partner was not successfully processed, resulting in delays to associated payments.
The incident was fully resolved on June 29, 2026, following successful processing of the sweep by the network partner and completion of the impacted payments.

Client Impact

A subset of customers experienced delays to DKK local payments. Once the outstanding sweep was processed, impacted payments were completed. No customer action was required.

Root Cause

An external network partner did not process a funding sweep within the expected timeframe. As a result, associated payments remained pending until confirmation of the sweep was received. Processing resumed once the sweep was completed.

Currencycloud Confidential
Posted Jun 30, 2026 - 16:58 UTC

Resolved

The issue impacting a subset of DKK local payments has now been resolved. The affected file has been successfully processed with our external network partners, and delayed payments have been completed.

We are continuing to work with the partner to understand the root cause and prevent recurrence.
Posted Jun 29, 2026 - 13:09 UTC

Investigating

We are currently investigating an issue impacting a subset of DKK local payments, where a file has not been successfully processed by an external network partner.

This is resulting in delays to affected payments, and our teams are actively working with the partner to validate and progress resolution.

Further updates will follow.
Posted Jun 27, 2026 - 23:57 UTC
This incident affected: Payments.