Direct paydirect.io Access Denied

Incident Report for Currencycloud

Postmortem

Overview

On 8 June 2026, an issue in our production environment temporarily affected access to Paydirect.io for customers using custom domains.

The disruption lasted approximately 37 minutes, during which some users were unable to access the DIRECT web interface and saw an “Access Denied” message.

The issue was quickly identified and resolved by rolling back a recent change, after which normal service was fully restored and monitored to ensure stability.

Client Impact

During this period, some customers may have experienced:

  • Difficulty accessing the DIRECT web interface via Paydirect.io
  • “Access Denied” messages when opening their custom domain URLs

The impact was limited to the web interface only. API services continued to operate normally throughout, and no data loss or data integrity issues occurred. No action is required from customers.

Root Cause

This change interacted unexpectedly with production configuration, resulting in valid requests from certain custom domains being incorrectly rejected.

CurrencyCloud Confidential

Posted Jun 09, 2026 - 19:26 UTC

Resolved

This incident has been resolved.
Posted Jun 08, 2026 - 11:05 UTC

Investigating

We are investigating reports of customers getting Access Denied when accessing their paydirect.io urls
Posted Jun 08, 2026 - 10:28 UTC
This incident affected: Paydirect.io / Direct.