Local EUR Payment Processing Delays

Incident Report for Currencycloud

Monitoring

The issue affecting local EUR payment services through our banking partners has been resolved and services have been restored. Payment processing and virtual account services are operating normally once again.

Our teams are completing recovery activities for a small number of transactions impacted during the outage and are monitoring the service closely to ensure a full return to normal operations. Customer funds remain secure.

We will continue to monitor the service and provide a further update once all recovery activities have been completed.
Posted Jul 21, 2026 - 12:28 UTC

Identified

We have identified an issue affecting local EUR payment services through our banking partners. As a result, some EUR payments may experience delays, and the creation of new EUR virtual accounts may be temporarily unavailable.

Our banking partner has identified the underlying cause and is actively implementing a fix. We are working closely with them and continue to monitor progress while taking steps to minimise customer impact.

Customer funds remain secure, and we will provide further updates as more information becomes available
Posted Jul 21, 2026 - 11:54 UTC

Investigating

We are currently investigating an issue affecting local EUR payment services through our banking partners. As a result, some payments may experience delays while we work to restore normal service.

Our teams are actively engaged with the provider and are taking steps to minimise customer impact.

Customer funds remain secure, and we will provide further updates as more information becomes available.
Posted Jul 21, 2026 - 11:41 UTC
This incident affects: Payments, Paydirect.io / Direct, and Other.