Payment Tracking Unavailable

Incident Report for Currencycloud

Postmortem

Overview

A certificate used by the Swift Microgateway service reached its expiry. resulting in a number of requests passing through the gateway returning with “expired certificate” error messages.

Client Impact

The Swift payment tracking flow experienced temporary failures.

Root Cause

The issue stemmed from the certificate lifecycle reaching its end, which only became visible once the expiration date was reached on live hosts. Once each host was updated, connectivity and authentication validated successfully.

Posted Mar 04, 2026 - 17:19 UTC

Resolved

The incident has now been resolved.
Posted Mar 02, 2026 - 12:40 UTC

Investigating

We are investigating an issue that is impacting clients using Payment Tracking for SWIFT Payments.
Posted Mar 02, 2026 - 10:00 UTC
This incident affected: API.